Pawel Solyga <Pawel.Solyga@gmail.com> [Fri, 05 Dec 2008 12:24:02 +0000] rev 664
Some style fixes in soc.logic.helper.notifications module. Little changes in welcome.html template.
Patch by: Pawel Solyga
Sverre Rabbelier <srabbelier@gmail.com> [Thu, 04 Dec 2008 10:09:38 +0000] rev 663
Make base.View.create lookup the scope if appropriate
Also re-introduce the custom description of the list selection for
the redirection.
Patch by: Sverre Rabbelier
Sverre Rabbelier <srabbelier@gmail.com> [Wed, 03 Dec 2008 23:49:10 +0000] rev 662
Make use of the new generic key_name by lookup up scope_path
This way base classes do not have to look up the 'scope' property,
instead they can rely on the base class to do it for them provided
they define the 'scope_logic' param.
Patch by: Sverre Rabbelier
Sverre Rabbelier <srabbelier@gmail.com> [Wed, 03 Dec 2008 23:48:33 +0000] rev 661
Change the key name to not include entity type
This allows for direct lookup by scope_path, rather than having to
do more complex things.
Patch by: Sverre Rabbelier
Sverre Rabbelier <srabbelier@gmail.com> [Wed, 03 Dec 2008 23:48:10 +0000] rev 660
Introduced django_extra_patterns
This way no classes ever need to override the getDjangoURLPatterns,
which results in less code, which is also more clear (that is, it is
immediately obvious that a View adds an extra mapping if it sets
the new django_extra_patterns value, or that it overrides the mapping
when it sets django_patterns_defaults.
Patch by: Sverre Rabbelier
Sverre Rabbelier <srabbelier@gmail.com> [Wed, 03 Dec 2008 21:28:16 +0000] rev 659
Make scope_path required for program
Patch by: Sverre Rabbelier
Sverre Rabbelier <srabbelier@gmail.com> [Wed, 03 Dec 2008 21:27:52 +0000] rev 658
Factor out the Group part of Sponsor
This makes it possible to reuse the Group logic.
Patch by: Sverre Rabbelier
Sverre Rabbelier <srabbelier@gmail.com> [Wed, 03 Dec 2008 21:27:27 +0000] rev 657
Rename role.RoleView to role.View
Patch by: Sverre Rabbelier
Sverre Rabbelier <srabbelier@gmail.com> [Wed, 03 Dec 2008 21:27:01 +0000] rev 656
Cleanups in the views module
Mainly rename from original_params to new_params (so that the keyword
argument in the __init__ method is the same for all). Also use
super(View, self) where appropriate.
Patch by: Sverre Rabbelier
Sverre Rabbelier <srabbelier@gmail.com> [Wed, 03 Dec 2008 21:26:16 +0000] rev 655
Cleanups to the logic module
Mainly converting to super(Logic, self) and adding some missing
empty lines while at it.
Patch by: Sverre Rabbelier