Seperated Logic for ProjectSurvey and GradingProject surveys.
These changes also include their respective records.
#!/usr/bin/make -f
# Sample debian/rules that uses debhelper.
# GNU copyright 1997 to 1999 by Joey Hess.
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
PYTHON=python
PACKAGE=vcs-load-dirs
CFLAGS = -Wall -g
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
CFLAGS += -O0
else
CFLAGS += -O2
endif
ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
INSTALL_PROGRAM += -s
endif
configure: configure-stamp
configure-stamp:
dh_testdir
# Add here commands to configure the package.
touch configure-stamp
build: build-stamp
build-stamp: configure-stamp
dh_testdir
# Add here commands to compile the package.
#/usr/bin/docbook-to-man debian/tla-load-dirs.sgml > tla-load-dirs.1
cd docs && make manpages
$(PYTHON) setup.py build
touch build-stamp
clean:
dh_testdir
dh_testroot
rm -f build-stamp configure-stamp
# Add here commands to clean up after the build process.
#-$(MAKE) clean
-$(PYTHON) setup.py clean
-rm -rf ./++* ./,,*
-rm -rf build
-cd docs; make realclean
dh_clean
install: build
dh_testdir
dh_testroot
dh_clean -k
dh_installdirs
# Add here commands to install the package into debian/tla-load-dirs.
#$(MAKE) install DESTDIR=$(CURDIR)/debian/tla-load-dirs
mkdir debian/tmp
$(PYTHON) setup.py install --root=`pwd`/debian/tmp \
--no-compile
binary-arch: build install
# We have nothing to do by default.
# Build architecture-dependent files here.
binary-indep: build install
dh_testdir
dh_testroot
dh_installchangelogs -i
dh_installdocs -i
dh_installexamples -i
dh_install -i
# dh_installmenu
# dh_installdebconf
# dh_installlogrotate
# dh_installemacsen
# dh_installpam
# dh_installmime
# dh_installinit
# dh_installcron
# dh_installinfo
dh_installman -i
dh_link -i
dh_strip -i
dh_compress -i
dh_fixperms -i
# dh_perl
dh_pycentral
dh_python -i
# dh_makeshlibs
dh_installdeb -i
dh_shlibdeps -i
dh_gencontrol -i
dh_md5sums -i
dh_builddeb -i
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install configure