|
1 #!/usr/bin/make -f |
|
2 # Sample debian/rules that uses debhelper. |
|
3 # GNU copyright 1997 to 1999 by Joey Hess. |
|
4 |
|
5 # Uncomment this to turn on verbose mode. |
|
6 #export DH_VERBOSE=1 |
|
7 |
|
8 PYTHON=python |
|
9 PACKAGE=vcs-load-dirs |
|
10 |
|
11 |
|
12 CFLAGS = -Wall -g |
|
13 |
|
14 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) |
|
15 CFLAGS += -O0 |
|
16 else |
|
17 CFLAGS += -O2 |
|
18 endif |
|
19 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS))) |
|
20 INSTALL_PROGRAM += -s |
|
21 endif |
|
22 |
|
23 configure: configure-stamp |
|
24 configure-stamp: |
|
25 dh_testdir |
|
26 # Add here commands to configure the package. |
|
27 |
|
28 touch configure-stamp |
|
29 |
|
30 |
|
31 build: build-stamp |
|
32 |
|
33 build-stamp: configure-stamp |
|
34 dh_testdir |
|
35 |
|
36 # Add here commands to compile the package. |
|
37 #/usr/bin/docbook-to-man debian/tla-load-dirs.sgml > tla-load-dirs.1 |
|
38 cd docs && make manpages |
|
39 $(PYTHON) setup.py build |
|
40 touch build-stamp |
|
41 |
|
42 clean: |
|
43 dh_testdir |
|
44 dh_testroot |
|
45 rm -f build-stamp configure-stamp |
|
46 |
|
47 # Add here commands to clean up after the build process. |
|
48 #-$(MAKE) clean |
|
49 -$(PYTHON) setup.py clean |
|
50 -rm -rf ./++* ./,,* |
|
51 -rm -rf build |
|
52 -cd docs; make realclean |
|
53 dh_clean |
|
54 |
|
55 install: build |
|
56 dh_testdir |
|
57 dh_testroot |
|
58 dh_clean -k |
|
59 dh_installdirs |
|
60 |
|
61 # Add here commands to install the package into debian/tla-load-dirs. |
|
62 #$(MAKE) install DESTDIR=$(CURDIR)/debian/tla-load-dirs |
|
63 mkdir debian/tmp |
|
64 $(PYTHON) setup.py install --root=`pwd`/debian/tmp \ |
|
65 --no-compile |
|
66 |
|
67 |
|
68 binary-arch: build install |
|
69 # We have nothing to do by default. |
|
70 |
|
71 # Build architecture-dependent files here. |
|
72 binary-indep: build install |
|
73 dh_testdir |
|
74 dh_testroot |
|
75 dh_installchangelogs -i |
|
76 dh_installdocs -i |
|
77 dh_installexamples -i |
|
78 dh_install -i |
|
79 # dh_installmenu |
|
80 # dh_installdebconf |
|
81 # dh_installlogrotate |
|
82 # dh_installemacsen |
|
83 # dh_installpam |
|
84 # dh_installmime |
|
85 # dh_installinit |
|
86 # dh_installcron |
|
87 # dh_installinfo |
|
88 dh_installman -i |
|
89 dh_link -i |
|
90 dh_strip -i |
|
91 dh_compress -i |
|
92 dh_fixperms -i |
|
93 # dh_perl |
|
94 dh_pycentral |
|
95 dh_python -i |
|
96 # dh_makeshlibs |
|
97 dh_installdeb -i |
|
98 dh_shlibdeps -i |
|
99 dh_gencontrol -i |
|
100 dh_md5sums -i |
|
101 dh_builddeb -i |
|
102 |
|
103 binary: binary-indep binary-arch |
|
104 .PHONY: build clean binary-indep binary-arch binary install configure |